samba_4.4.5.bb 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254
  1. SECTION = "console/network"
  2. LICENSE = "GPL-3.0+ & LGPL-3.0+ & GPL-2.0+"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
  4. file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b \
  5. file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 "
  6. SAMBA_MIRROR = "http://samba.org/samba/ftp"
  7. MIRRORS += "\
  8. ${SAMBA_MIRROR} http://mirror.internode.on.net/pub/samba \n \
  9. ${SAMBA_MIRROR} http://www.mirrorservice.org/sites/ftp.samba.org \n \
  10. "
  11. SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
  12. file://00-fix-typos-in-man-pages.patch \
  13. file://10-use-only-libsystemd.patch \
  14. file://16-do-not-check-xsltproc-manpages.patch \
  15. file://20-do-not-import-target-module-while-cross-compile.patch \
  16. file://21-add-config-option-without-valgrind.patch \
  17. file://0001-packaging-Avoid-timeout-for-nmbd-if-started-offline-.patch \
  18. file://0006-avoid-using-colon-in-the-checking-msg.patch \
  19. file://volatiles.03_samba \
  20. "
  21. SRC_URI_append_libc-musl = " \
  22. file://samba-4.2.7-pam.patch \
  23. file://samba-4.3.9-remove-getpwent_r.patch \
  24. "
  25. SRC_URI[md5sum] = "6950c5e9f7bdeb8a610c2ca957a15be4"
  26. SRC_URI[sha256sum] = "b876ef2e63f66265490e80a122e66ef2d7616112b839df68f56ac2e1ce17a7bd"
  27. inherit systemd waf-samba cpan-base perlnative update-rc.d
  28. # remove default added RDEPENDS on perl
  29. RDEPENDS_${PN}_remove = "perl"
  30. DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb krb5 libbsd libaio libpam"
  31. DEPENDS_append_libc-musl = " libtirpc"
  32. CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
  33. LDFLAGS_append_libc-musl = " -ltirpc"
  34. LSB = ""
  35. LSB_linuxstdbase = "lsb"
  36. INITSCRIPT_NAME = "samba"
  37. INITSCRIPT_PARAMS = "start 20 3 5 . stop 20 0 1 6 ."
  38. SYSTEMD_PACKAGES = "${PN}-base winbind"
  39. SYSTEMD_SERVICE_${PN}-base = "nmb.service smb.service"
  40. SYSTEMD_SERVICE_winbind = "winbind.service"
  41. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd zeroconf', d)} \
  42. acl cups ldap \
  43. "
  44. RDEPENDS_${PN}-base += "${LSB}"
  45. RDEPENDS_${PN}-ctdb-tests += "bash util-linux-getopt"
  46. PACKAGECONFIG[acl] = "--with-acl-support,--without-acl-support,acl"
  47. PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
  48. PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups"
  49. PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
  50. PACKAGECONFIG[sasl] = ",,cyrus-sasl"
  51. PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
  52. PACKAGECONFIG[dmapi] = "--with-dmapi,--without-dmapi,dmapi"
  53. PACKAGECONFIG[zeroconf] = "--enable-avahi,--disable-avahi,avahi"
  54. PACKAGECONFIG[valgrind] = ",--without-valgrind,valgrind,"
  55. PACKAGECONFIG[lttng] = "--with-lttng, --without-lttng,lttng-ust"
  56. PACKAGECONFIG[archive] = "--with-libarchive, --without-libarchive, libarchive"
  57. SAMBA4_IDMAP_MODULES="idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2"
  58. SAMBA4_PDB_MODULES="pdb_tdbsam,${@bb.utils.contains('PACKAGECONFIG', 'ldap', 'pdb_ldap,', '', d)}pdb_ads,pdb_smbpasswd,pdb_wbc_sam,pdb_samba4"
  59. SAMBA4_AUTH_MODULES="auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,auth_samba4"
  60. SAMBA4_MODULES="${SAMBA4_IDMAP_MODULES},${SAMBA4_PDB_MODULES},${SAMBA4_AUTH_MODULES}"
  61. SAMBA4_LIBS="heimdal,!zlib,!popt,!talloc,!pytalloc,!pytalloc-util,!tevent,!pytevent,!tdb,!pytdb,!ldb,!pyldb"
  62. EXTRA_OECONF += "--enable-fhs \
  63. --with-piddir=/run \
  64. --with-sockets-dir=/run/samba \
  65. --with-modulesdir=${libdir}/samba \
  66. --with-lockdir=${localstatedir}/lib/samba \
  67. --with-cachedir=${localstatedir}/lib/samba \
  68. --disable-gnutls \
  69. --disable-rpath-install \
  70. --with-shared-modules=${SAMBA4_MODULES} \
  71. --bundled-libraries=${SAMBA4_LIBS} \
  72. --with-system-mitkrb5 \
  73. --without-ad-dc \
  74. ${@base_conditional('TARGET_ARCH', 'x86_64', '', '--disable-glusterfs', d)} \
  75. --with-cluster-support \
  76. --with-profiling-data \
  77. --with-libiconv=${STAGING_DIR_HOST}${prefix} \
  78. --with-pam --with-pammodulesdir=${base_libdir}/security \
  79. "
  80. LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
  81. do_install_append() {
  82. for section in 1 5 7; do
  83. install -d ${D}${mandir}/man$section
  84. install -m 0644 ctdb/doc/*.$section ${D}${mandir}/man$section
  85. done
  86. for section in 1 5 7 8; do
  87. install -d ${D}${mandir}/man$section
  88. install -m 0644 docs/manpages/*.$section ${D}${mandir}/man$section
  89. done
  90. install -d ${D}${systemd_system_unitdir}
  91. install -m 0644 packaging/systemd/*.service ${D}${systemd_system_unitdir}
  92. sed -e 's,\(ExecReload=\).*\(/kill\),\1${base_bindir}\2,' \
  93. -e 's,/etc/sysconfig/samba,${sysconfdir}/default/samba,' \
  94. -i ${D}${systemd_system_unitdir}/*.service
  95. install -d ${D}${sysconfdir}/tmpfiles.d
  96. install -m644 packaging/systemd/samba.conf.tmp ${D}${sysconfdir}/tmpfiles.d/samba.conf
  97. echo "d ${localstatedir}/log/samba 0755 root root -" \
  98. >> ${D}${sysconfdir}/tmpfiles.d/samba.conf
  99. if [ "${LSB}" = "lsb" ]; then
  100. install -d ${D}${sysconfdir}/init.d
  101. install -m 0755 packaging/LSB/samba.sh ${D}${sysconfdir}/init.d/samba
  102. else
  103. install -d ${D}${sysconfdir}/init.d
  104. install -m 0755 packaging/sysv/samba.init ${D}${sysconfdir}/init.d/samba
  105. sed -e 's,/opt/samba/bin,${sbindir},g' \
  106. -e 's,/opt/samba/smb.conf,${sysconfdir}/samba/smb.conf,g' \
  107. -e 's,/opt/samba/log,${localstatedir}/log/samba,g' \
  108. -e 's,/etc/init.d/samba.server,${sysconfdir}/init.d/samba,g' \
  109. -e 's,/usr/bin,${base_bindir},g' \
  110. -i ${D}${sysconfdir}/init.d/samba
  111. fi
  112. install -d ${D}${sysconfdir}/samba
  113. echo "127.0.0.1 localhost" > ${D}${sysconfdir}/samba/lmhosts
  114. install -m644 packaging/LSB/smb.conf ${D}${sysconfdir}/samba/smb.conf
  115. install -D -m 644 ${WORKDIR}/volatiles.03_samba ${D}${sysconfdir}/default/volatiles/03_samba
  116. install -d ${D}${sysconfdir}/default
  117. install -m644 packaging/systemd/samba.sysconfig ${D}${sysconfdir}/default/samba
  118. # install ctdb config file and test cases
  119. install -D -m 0644 ${S}/ctdb/tests/onnode/nodes ${D}${sysconfdir}/ctdb/nodes
  120. # the items are from ctdb/tests/run_tests.sh
  121. for d in onnode takeover tool eventscripts cunit simple complex; do
  122. testdir=${D}${datadir}/ctdb-tests/$d
  123. install -d $testdir
  124. cp ${S}/ctdb/tests/$d/*.sh $testdir
  125. cp -r ${S}/ctdb/tests/$d/scripts ${S}/ctdb/tests/$d/stubs $testdir || true
  126. done
  127. # fix file-rdeps qa warning
  128. if [ -f ${D}${bindir}/onnode ]; then
  129. sed -i 's:\(#!/bin/\)bash:\1sh:' ${D}${bindir}/onnode
  130. fi
  131. rm -rf ${D}/run ${D}${localstatedir}/run ${D}${localstatedir}/log
  132. }
  133. PACKAGES =+ "${PN}-python ${PN}-pidl \
  134. ${PN}-dsdb-modules ${PN}-testsuite registry-tools \
  135. winbind \
  136. ${PN}-common ${PN}-base ${PN}-ctdb-tests \
  137. smbclient"
  138. python samba_populate_packages() {
  139. def module_hook(file, pkg, pattern, format, basename):
  140. pn = d.getVar('PN', True)
  141. d.appendVar('RRECOMMENDS_%s-base' % pn, ' %s' % pkg)
  142. mlprefix = d.getVar('MLPREFIX', True) or ''
  143. pam_libdir = d.expand('${base_libdir}/security')
  144. pam_pkgname = mlprefix + 'pam-plugin%s'
  145. do_split_packages(d, pam_libdir, '^pam_(.*)\.so$', pam_pkgname, 'PAM plugin for %s', extra_depends='', prepend=True)
  146. libdir = d.getVar('libdir', True)
  147. do_split_packages(d, libdir, '^lib(.*)\.so\..*$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True, allow_links=True)
  148. pkglibdir = '%s/samba' % libdir
  149. do_split_packages(d, pkglibdir, '^lib(.*)\.so$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True)
  150. moduledir = '%s/samba/auth' % libdir
  151. do_split_packages(d, moduledir, '^(.*)\.so$', 'samba-auth-%s', 'Samba %s authentication backend', hook=module_hook, extra_depends='', prepend=True)
  152. moduledir = '%s/samba/pdb' % libdir
  153. do_split_packages(d, moduledir, '^(.*)\.so$', 'samba-pdb-%s', 'Samba %s password backend', hook=module_hook, extra_depends='', prepend=True)
  154. }
  155. PACKAGESPLITFUNCS_prepend = "samba_populate_packages "
  156. RDEPENDS_${PN} += "${PN}-base"
  157. FILES_${PN}-base = "${sbindir}/nmbd \
  158. ${sbindir}/smbd \
  159. ${sysconfdir}/init.d \
  160. ${localstatedir}/lib/samba \
  161. ${localstatedir}/nmbd \
  162. ${localstatedir}/spool/samba \
  163. ${systemd_system_unitdir}/nmb.service \
  164. ${systemd_system_unitdir}/samba.service \
  165. ${systemd_system_unitdir}/smb.service"
  166. FILES_${PN}-ctdb-tests = "${bindir}/ctdb_run_tests \
  167. ${bindir}/ctdb_run_cluster_tests \
  168. ${sysconfdir}/ctdb/nodes \
  169. ${libdir}/ctdb-tests \
  170. ${datadir}/ctdb-tests \
  171. /run/ctdb \
  172. "
  173. FILES_${BPN}-common = "${sysconfdir}/default \
  174. ${sysconfdir}/samba \
  175. ${sysconfdir}/tmpfiles.d \
  176. "
  177. FILES_${PN} += "${libdir}/vfs/*.so \
  178. ${libdir}/charset/*.so \
  179. ${libdir}/*.dat \
  180. ${libdir}/auth/*.so \
  181. "
  182. FILES_${PN}-dsdb-modules = "${libdir}/samba/ldb"
  183. FILES_${PN}-testsuite = "${bindir}/gentest \
  184. ${bindir}/locktest \
  185. ${bindir}/masktest \
  186. ${bindir}/ndrdump \
  187. ${bindir}/smbtorture"
  188. FILES_registry-tools = "${bindir}/regdiff \
  189. ${bindir}/regpatch \
  190. ${bindir}/regshell \
  191. ${bindir}/regtree"
  192. FILES_winbind = "${sbindir}/winbindd \
  193. ${bindir}/wbinfo \
  194. ${bindir}/ntlm_auth \
  195. ${libdir}/samba/idmap \
  196. ${libdir}/samba/nss_info \
  197. ${libdir}/winbind_krb5_locator.so \
  198. ${sysconfdir}/init.d/winbind \
  199. ${systemd_system_unitdir}/winbind.service"
  200. FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
  201. FILES_smbclient = "${bindir}/cifsdd \
  202. ${bindir}/rpcclient \
  203. ${bindir}/smbcacls \
  204. ${bindir}/smbclient \
  205. ${bindir}/smbcquotas \
  206. ${bindir}/smbget \
  207. ${bindir}/smbspool \
  208. ${bindir}/smbtar \
  209. ${bindir}/smbtree \
  210. ${libdir}/samba/smbspool_krb5_wrapper"
  211. RDEPENDS_${PN}-pidl_append = " perl"
  212. FILES_${PN}-pidl = "${bindir}/pidl ${datadir}/perl5/Parse"