libao_1.2.0.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Cross-platform audio output library and plugins"
  2. DESCRIPTION = "Libao is a cross-platform audio library that allows programs to \
  3. output audio using a simple API on a wide variety of platforms."
  4. SECTION = "multimedia"
  5. HOMEPAGE = "https://www.xiph.org/ao/"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  8. SRC_URI="http://downloads.xiph.org/releases/ao/${BP}.tar.gz"
  9. SRC_URI[md5sum] = "9f5dd20d7e95fd0dd72df5353829f097"
  10. SRC_URI[sha256sum] = "03ad231ad1f9d64b52474392d63c31197b0bc7bd416e58b1c10a329a5ed89caf"
  11. inherit autotools
  12. PACKAGES += "${BPN}-ckport"
  13. PACKAGES_DYNAMIC += "^${BPN}-plugin-.*"
  14. do_install_append () {
  15. find "${D}" -name '*.la' -exec rm -f {} +
  16. }
  17. python populate_packages_prepend () {
  18. rootdir = bb.data.expand('${libdir}/ao/plugins-4', d)
  19. rootdir_dbg = bb.data.expand('${libdir}/ao/plugins-4/.debug', d)
  20. do_split_packages(d, rootdir, '^(.*)\.so$', output_pattern='${BPN}-plugin-%s', description='AO %s plugin')
  21. do_split_packages(d, rootdir_dbg, '^(.*)\.so$', output_pattern='${BPN}-plugin-%s-dbg', description='AO %s plugin debug data')
  22. }
  23. PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)}"
  24. PACKAGECONFIG[esound] = "--enable-esd,--disable-esd,esound"
  25. PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
  26. PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
  27. FILES_${BPN}-ckport = "${libdir}/ckport"