gradm_3.1-201903191516.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. SUMMARY = "Administration program for the grsecurity RBAC syste"
  2. DESCRIPTION = "\
  3. gradm is the userspace RBAC parsing and authentication program for \
  4. grsecurity grsecurity aims to be a complete security system. gradm \
  5. performs several tasks for the RBAC system including authenticated \
  6. via a password to the kernel and parsing rules to be passed to the \
  7. kernel"
  8. HOMEPAGE = "http://grsecurity.net/index.php"
  9. SECTION = "admin"
  10. LICENSE = "GPL-2.0"
  11. LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
  12. DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
  13. SRC_URI = "http://grsecurity.net/stable/${BP}.tar.gz \
  14. file://0001-Makefile-remove-strip.patch \
  15. file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
  16. "
  17. SRC_URI[md5sum] = "5099c715433981d5a3eed8ded7c5bbc0"
  18. SRC_URI[sha256sum] = "d3a0b6383ff97a2054941d71133c737efae66afdd8eef59346c031ae15c75ff3"
  19. S = "${WORKDIR}/gradm"
  20. inherit autotools-brokensep
  21. do_compile() {
  22. oe_runmake 'CC=${CC}' \
  23. 'LIBS=' \
  24. 'OPT_FLAGS=${CFLAGS}' \
  25. 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
  26. 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
  27. 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
  28. ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
  29. }
  30. do_install() {
  31. oe_runmake 'CC=${CC}' \
  32. 'DESTDIR=${D}' \
  33. 'LIBS=' \
  34. 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
  35. 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
  36. 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
  37. install
  38. # The device nodes are generated by postinstall or udev
  39. rm -rf ${D}/dev
  40. }
  41. pkg_postinst_ontarget_${PN}() {
  42. /bin/mknod -m 0622 /dev/grsec c 1 13
  43. }