sblim-sfcb_1.4.9.bb 3.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. SUMMARY = "Small Footprint CIM Broker"
  2. DESCRIPTION = "\
  3. Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \
  4. Operations over HTTP protocol. It is robust, with low resource consumption \
  5. and therefore specifically suited for embedded and resource constrained \
  6. environments. sfcb supports providers written against the Common \
  7. Manageability Programming Interface (CMPI)."
  8. HOMEPAGE = "http://www.sblim.org"
  9. SECTION = "Applications/System"
  10. LICENSE = "EPL-1.0"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
  12. DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
  13. inherit features_check
  14. REQUIRED_DISTRO_FEATURES = "pam"
  15. SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
  16. file://sfcb.service \
  17. file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
  18. file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
  19. file://sblim-sfcb-1.3.16-maxMsgLen.patch \
  20. file://sblim-sfcb-1.4.5-service.patch \
  21. file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
  22. file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
  23. file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
  24. file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \
  25. file://0001-Replace-need-for-error.h-when-it-does-not-exist.patch \
  26. file://sblim-sfcb-1.4.9-fix-sfcbinst2mof.patch \
  27. file://0001-Avoid-variable-definition-in-header-files.patch \
  28. "
  29. SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
  30. SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
  31. inherit autotools
  32. inherit systemd
  33. SYSTEMD_PACKAGES = "${PN}"
  34. SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
  35. SYSTEMD_AUTO_ENABLE = "enable"
  36. LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
  37. EXTRA_OECONF = '--enable-debug \
  38. --enable-ssl \
  39. --enable-pam \
  40. --enable-ipv6 \
  41. CFLAGS="${CFLAGS} -D_GNU_SOURCE"'
  42. # make all with -j option is unsafe.
  43. PARALLEL_MAKE = ""
  44. INSANE_SKIP_${PN} = "dev-so"
  45. CONFIG_SITE = "${WORKDIR}/config-site.${P}"
  46. do_install() {
  47. cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg
  48. oe_runmake DESTDIR=${D} install
  49. install -d ${D}${systemd_unitdir}/system
  50. install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
  51. install -d ${D}${sysconfdir}/init.d
  52. mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
  53. sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb
  54. rm -rf ${D}${libdir}/sfcb/*.la
  55. }
  56. pkg_postinst_${PN} () {
  57. $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX}
  58. }
  59. pkg_postinst_ontarget_${PN} () {
  60. ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
  61. ${bindir}/sfcbrepos -f
  62. }
  63. FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb"
  64. FILES_${PN}-dbg += "${libdir}/sfcb/.debug"
  65. RDEPENDS_${PN} = "perl bash"