python-cryptography_1.1.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
  2. SECTION = "devel/python"
  3. LICENSE = "Apache-2.0 | BSD"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
  5. DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
  6. SRCNAME = "cryptography"
  7. SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
  8. file://run-ptest \
  9. "
  10. S = "${WORKDIR}/${SRCNAME}-${PV}"
  11. SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f"
  12. SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d"
  13. inherit pypi
  14. RDEPENDS_${PN} = "\
  15. python-pyasn1\
  16. python-six\
  17. python-cffi\
  18. python-enum34\
  19. python-setuptools\
  20. python-pycparser\
  21. python-subprocess\
  22. python-threading\
  23. python-numbers\
  24. python-contextlib\
  25. python-ipaddress\
  26. python-pyasn1\
  27. python-idna\
  28. "
  29. RDEPENDS_${PN}-ptest = "\
  30. ${PN}\
  31. python-pytest\
  32. python-pretend\
  33. python-iso8601\
  34. python-cryptography-vectors\
  35. "
  36. inherit ptest
  37. do_install_ptest() {
  38. install -d ${D}${PTEST_PATH}/tests
  39. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  40. install -d ${D}${PTEST_PATH}/tests/hazmat
  41. cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
  42. }
  43. FILES_${PN}-dbg += " \
  44. ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
  45. "