portaudio-v19_20161030.bb 960 B

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "A portable audio library"
  2. SECTION = "libs/multimedia"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df"
  5. PV = "v190600"
  6. SRC_URI = "http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz \
  7. file://ldflags.patch"
  8. SRC_URI[md5sum] = "4df8224e047529ca9ad42f0521bf81a8"
  9. SRC_URI[sha256sum] = "f5a21d7dcd6ee84397446fa1fa1a0675bb2e8a4a6dceb4305a8404698d8d1513"
  10. S = "${WORKDIR}/portaudio"
  11. inherit autotools pkgconfig
  12. PACKAGECONFIG ??= "alsa jack"
  13. PACKAGECONFIG[alsa] = "--with-alsa, --without-alsa, alsa-lib,"
  14. PACKAGECONFIG[jack] = "--with-jack, --without-jack, jack,"
  15. EXTRA_OECONF = "--without-oss --without-asihpi"
  16. do_install_append() {
  17. mkdir --parents ${D}${bindir}
  18. for b in ${B}/bin/pa*; do
  19. # Bit nasty, should always work
  20. ${B}/*-libtool --mode install install $b ${D}${bindir}
  21. done
  22. }
  23. PACKAGES += "portaudio-examples"
  24. FILES_portaudio-examples = "${bindir}"