poppler_0.22.4.bb 1.0 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  4. SRC_URI = " \
  5. http://poppler.freedesktop.org/${BP}.tar.gz \
  6. "
  7. SRC_URI[md5sum] = "49d55921ce795778c7231fe9f2fe923b"
  8. SRC_URI[sha256sum] = "4f438f34e63265e2da8427f3423f940ff41c26088922a9f5d976f795c1dce13b"
  9. DEPENDS = "fontconfig jpeg zlib gtk+ cairo tiff lcms"
  10. inherit autotools pkgconfig
  11. EXTRA_OECONF = "\
  12. --enable-xpdf-headers \
  13. --disable-gtk-test \
  14. --disable-poppler-qt4 \
  15. --enable-zlib \
  16. "
  17. # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
  18. def get_poppler_fpu_setting(bb, d):
  19. if d.getVar('TARGET_FPU', 1) in [ 'soft' ]:
  20. return "--enable-fixedpoint"
  21. return ""
  22. EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}"
  23. PACKAGES =+ "libpoppler libpoppler-glib"
  24. FILES_libpoppler = "${libdir}/libpoppler.so.*"
  25. FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
  26. RDEPENDS_${PN} = "poppler-data"