gdal_1.10.1.bb 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. SUMMARY = "GDAL is a translator library for raster geospatial data formats"
  2. HOMEPAGE = "http://www.gdal.org/"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=b9bd75ae5af7ff87ab259be0121c4106"
  5. DEPENDS = "proj sqlite3 tiff"
  6. SRC_URI = "ftp://download.osgeo.org/gdal/${PV}/${BP}.tar.xz"
  7. SRC_URI[md5sum] = "f354c614aea76e5630e4edbf06e5c292"
  8. SRC_URI[sha256sum] = "e6c9c6c4480228c943af29120d87435ddfe9ca460458bc60b91639fb8d443791"
  9. inherit autotools lib_package binconfig
  10. EXTRA_OECONF = "--without-perl \
  11. --without-php \
  12. --without-ruby \
  13. --without-python \
  14. \
  15. --without-grass \
  16. --without-libgrass \
  17. --without-cfitsio \
  18. --without-dds \
  19. --without-gta \
  20. --without-pcidsk \
  21. --without-ogdi \
  22. --without-fme \
  23. --without-hdf4 \
  24. --without-hdf5 \
  25. --without-pg \
  26. --without-jpeg12 \
  27. --without-ogdi \
  28. --without-netcdf \
  29. --without-openjpeg \
  30. --without-fgdb \
  31. --without-ecw \
  32. --without-kakadu \
  33. --without-mrsid \
  34. --without-jp2mrsid \
  35. --without-mrsid_lidar \
  36. --without-msg \
  37. --without-bsb \
  38. --without-grib \
  39. --without-mysql \
  40. --without-ingres \
  41. --without-odbc \
  42. --without-dods_root \
  43. --without-xml2 \
  44. --without-spatialite \
  45. --without-pcre \
  46. --without-dwgdirect \
  47. --without-dwgdirect \
  48. --without-idb \
  49. --without-sde \
  50. --without-sde-version \
  51. --without-epsilon \
  52. --without-webp \
  53. --without-opencl \
  54. --without-opencl-include \
  55. --without-opencl-lib \
  56. --without-freexl \
  57. --without-pam \
  58. --without-poppler \
  59. --without-podofo \
  60. --without-podofo-lib \
  61. --without-podofo-extra-lib-for-test \
  62. --without-static_proj4 \
  63. --without-perl \
  64. --without-php \
  65. --without-ruby \
  66. --without-python \
  67. --without-java \
  68. --without-mdb \
  69. --without-jvm-lib \
  70. --without-jvm-lib-add-rpath \
  71. --without-rasdaman \
  72. --without-armadillo \
  73. \
  74. --with-pcraster=internal \
  75. --with-geotiff=internal \
  76. \
  77. --with-sqlite3=${STAGING_LIBDIR} \
  78. --with-libtiff=${STAGING_LIBDIR} \
  79. "
  80. EXTRA_OEMAKE += "INST_DATA="${datadir}/gdal""
  81. PACKAGECONFIG ?= "geos png jasper"
  82. PACKAGECONFIG[geos] = "--with-geos,--without-geos,geos"
  83. PACKAGECONFIG[lzma] = "--with-liblzma,--without-liblzma,xz"
  84. PACKAGECONFIG[png] = "--with-png,--without-png,libpng"
  85. PACKAGECONFIG[gif] = "--with-gif,--without-gif,giflib"
  86. PACKAGECONFIG[jpeg] = "--with-jpeg,--without-jpeg,jpeg"
  87. PACKAGECONFIG[z] = "--with-libz,--without-libz,zlib"
  88. PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
  89. PACKAGECONFIG[curl] = "--with-curl,--without-curl,curl"
  90. do_configure_prepend () {
  91. # The configure script has many hardcoded paths to search
  92. # for the library headers when using external libraries,
  93. # workaround it.
  94. sed -e 's,/usr/include,NON_EXISTENT_DIR,g' \
  95. -e 's,/usr/lib,NON_EXISTENT_DIR,g' \
  96. -i ${S}/configure.in
  97. }
  98. FILES_${PN} += "${libdir}/gdalplugins"