wvdial_1.61.bb 838 B

123456789101112131415161718192021222324252627282930
  1. HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
  2. DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
  3. LICENSE = "LGPLv2"
  4. LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
  5. DEPENDS = "wvstreams"
  6. RDEPENDS_${PN} = "ppp"
  7. SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \
  8. file://typo_pon.wvdial.1.patch \
  9. "
  10. SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
  11. SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
  12. EXTRA_OEMAKE = ""
  13. export WVLINK="${LD}"
  14. PARALLEL_MAKE = ""
  15. BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams"
  16. do_configure() {
  17. sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
  18. }
  19. do_install() {
  20. oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
  21. }