packagegroup-meta-multimedia.bb 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. SUMMARY = "Meta-multimedia packagegroups"
  2. inherit packagegroup
  3. PROVIDES = "${PACKAGES}"
  4. PACKAGES = ' \
  5. packagegroup-meta-multimedia \
  6. packagegroup-meta-multimedia-connectivity \
  7. packagegroup-meta-multimedia-dvb \
  8. packagegroup-meta-multimedia-mkv \
  9. packagegroup-meta-multimedia-support \
  10. '
  11. RDEPENDS_packagegroup-meta-multimedia = "\
  12. packagegroup-meta-multimedia \
  13. packagegroup-meta-multimedia-connectivity \
  14. packagegroup-meta-multimedia-dvb \
  15. packagegroup-meta-multimedia-mkv \
  16. packagegroup-meta-multimedia-support \
  17. "
  18. RDEPENDS_packagegroup-meta-multimedia = "\
  19. alsa-equal \
  20. aom \
  21. caps \
  22. cdparanoia \
  23. dcadec \
  24. dleyna-connector-dbus \
  25. dleyna-core \
  26. dleyna-renderer \
  27. dleyna-server \
  28. dvb-apps \
  29. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "faac", "", d)} \
  30. fdk-aac \
  31. gerbera \
  32. libao \
  33. libavc1394 \
  34. libdc1394 \
  35. libdvbpsi \
  36. libdvdnav \
  37. libiec61883 \
  38. fluidsynth \
  39. libmusicbrainz \
  40. libmpdclient \
  41. mpc \
  42. mpd \
  43. ncmpc \
  44. libmpd \
  45. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "opencore-amr vo-aacenc vo-amrwbenc", "", d)} \
  46. gst-shark \
  47. gstd \
  48. rtmpdump \
  49. bigbuckbunny-1080p \
  50. bigbuckbunny-480p \
  51. bigbuckbunny-720p \
  52. tearsofsteel-1080p \
  53. schroedinger \
  54. projucer \
  55. libcamera \
  56. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libde265 openh264", "", d)} \
  57. vorbis-tools \
  58. libdvbcsa \
  59. libopenmpt \
  60. libuvc \
  61. mimic \
  62. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "minidlna", "", d)} \
  63. mycroft \
  64. openal-soft \
  65. opusfile \
  66. libdvdcss \
  67. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "vlc", "", d)} \
  68. ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "sox streamripper", "", d)} \
  69. tinyalsa \
  70. tremor \
  71. webrtc-audio-processing \
  72. ${@bb.utils.contains_any("TRANSLATED_TARGET_ARCH", "i586 x86-64", "x265", "", d)} \
  73. "
  74. RDEPENDS_packagegroup-meta-multimedia_remove_libc-musl = "projucer"
  75. RDEPENDS_packagegroup-meta-multimedia-connectivity = "\
  76. gssdp \
  77. gupnp-av \
  78. gupnp-dlna \
  79. gupnp-igd \
  80. ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gupnp-tools", "", d)} \
  81. gupnp \
  82. libupnp \
  83. rygel \
  84. "
  85. RDEPENDS_packagegroup-meta-multimedia-dvb = "\
  86. oscam \
  87. tvheadend \
  88. "
  89. RDEPENDS_packagegroup-meta-multimedia-mkv = "\
  90. libebml \
  91. libmatroska \
  92. "
  93. RDEPENDS_packagegroup-meta-multimedia-support = "\
  94. crossguid \
  95. libmediaart-2.0 \
  96. libmediaart \
  97. gst-instruments \
  98. libsrtp \
  99. "
  100. # devel headers/libraries only packages
  101. # libsquish