spdlog_1.8.1.bb 834 B

12345678910111213141516171819202122
  1. DESCRIPTION = "Very fast, header only, C++ logging library."
  2. HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
  5. SRCREV = "cbe9448650176797739dbab13961ef4c07f4290f"
  6. SRC_URI = "git://github.com/gabime/spdlog.git;protocol=git;branch=v1.x; \
  7. file://0001-Enable-use-of-external-fmt-library.patch"
  8. DEPENDS += "fmt"
  9. S = "${WORKDIR}/git"
  10. BBCLASSEXTEND = "native"
  11. # no need to build example&text&benchmarks on pure yocto
  12. EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLES=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
  13. inherit cmake
  14. # Header-only library
  15. RDEPENDS_${PN}-dev = ""
  16. RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"