grubby_git.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "A command line tool for updating and displaying info about boot loaders"
  2. DESCRIPTION = "grubby is a command line tool for updating and displaying information \
  3. about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
  4. zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
  5. new kernels and need to find information about the current boot environment. \
  6. "
  7. HOMEPAGE = "https://github.com/rhboot/grubby"
  8. LICENSE = "GPLv2+"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
  10. DEPENDS = "popt util-linux"
  11. DEPENDS_append_libc-musl = " libexecinfo"
  12. S = "${WORKDIR}/git"
  13. SRCREV = "a1d2ae93408c3408e672d7eba4550fdf27fb0201"
  14. SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https; \
  15. file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
  16. file://run-ptest \
  17. file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
  18. file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
  19. "
  20. RDEPENDS_${PN} += "dracut"
  21. inherit autotools-brokensep ptest
  22. EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}' 'PREFIX'=${@bb.utils.contains('DISTRO_FEATURES','usrmerge','/usr','',d)}"
  23. LIBS_libc-musl = "-lexecinfo"
  24. LIBS ?= ""
  25. do_install_ptest() {
  26. install -d ${D}${PTEST_PATH}
  27. cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
  28. sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
  29. }
  30. RDEPENDS_${PN} += "bash"
  31. RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
  32. COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'