Browse Source

python3-matplotlib: Disable LTO for clang/riscv

LTO fails to link on RV32/RV64

| Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (
ignoring target-abi)
| riscv64-yoe-linux-ld.lld: error: lto.tmp: cannot link object files with different floating-point ABI

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
f623d8b574
1 changed files with 3 additions and 0 deletions
  1. 3 0
      meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb

+ 3 - 0
meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb

@@ -38,9 +38,12 @@ RDEPENDS_${PN} = "\
     python3-pytz \
 "
 
+ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
+ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
 do_compile_prepend() {
     echo [libs] > ${S}/setup.cfg
     echo system_freetype = true >> ${S}/setup.cfg
+    ${ENABLELTO}
 }
 
 BBCLASSEXTEND = "native"