Browse Source

wireshark: Enable plugins when enabling qt5

plugins tab and about dialog have created dependency with commit[1]
this fails to build when qt5 is in bblayers

Fixes

wireshark-3.2.0/ui/qt/about_dialog.cpp:137:29: error: 'plugins_add_description' was not declared in this scope; did you mean 'plugins_get_descriptions'?
  137 |     extcap_get_descriptions(plugins_add_description, &plugin_data);
      |                             ^~~~~~~~~~~~~~~~~~~~~~~
      |                             plugins_get_descriptions

[1] https://github.com/wireshark/wireshark/commit/5dfde7ff83a35bb7186cd05ce61f4b139ab01203

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 years ago
parent
commit
f472089319
1 changed files with 1 additions and 1 deletions
  1. 1 1
      meta-networking/recipes-support/wireshark/wireshark_3.2.0.bb

+ 1 - 1
meta-networking/recipes-support/wireshark/wireshark_3.2.0.bb

@@ -19,7 +19,7 @@ PE = "1"
 
 inherit cmake pkgconfig python3native perlnative upstream-version-is-even
 
-PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
+PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5 plugins', '', d)}"
 
 PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh"