Browse Source

python3-soupsieve: Upgrade 2.0.1 -> 2.1

Upgrade to release 2.1:

- Officially support Python 3.9.
- Drop official support for Python 3.5.
- In order to avoid conflicts with future CSS specification
  changes, non-standard pseudo classes will now start with the
  :-soup- prefix. As a consequence, :contains() will now be known
  as :-soup-contains(), though for a time the deprecated form of
  :contains() will still be allowed with a warning that users
  should migrate over to :-soup-contains().
- Added new non-standard pseudo class :-soup-contains-own() which
  operates similar to :-soup-contains() except that it only looks
  at text nodes directly associated with the currently scoped
  element and not its descendants.
- Import bs4 globally instead of in local functions as it appears
  there are no adverse affects due to circular imports as bs4 does
  not immediately reference soupsieve functions and soupsieve does
  not immediately reference bs4 functions. This should give a
  performance boost to functions that had previously included bs4
  locally.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Leon Anavi 3 years ago
parent
commit
f3f0fc2d0e
1 changed files with 1 additions and 2 deletions
  1. 1 2
      meta-python/recipes-devtools/python/python3-soupsieve_2.1.bb

+ 1 - 2
meta-python/recipes-devtools/python/python3-soupsieve_2.0.1.bb → meta-python/recipes-devtools/python/python3-soupsieve_2.1.bb

@@ -4,8 +4,7 @@ HOMEPAGE = "https://github.com/facelessuser/soupsieve"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5a6fd3b0c24fc5a041a3d1bbb22c81b5"
 
-SRC_URI[md5sum] = "62a7481c7dbf6d8cc21e4e3a79c72034"
-SRC_URI[sha256sum] = "a59dc181727e95d25f781f0eb4fd1825ff45590ec8ff49eadfd7f1a537cc0232"
+SRC_URI[sha256sum] = "6dc52924dc0bc710a5d16794e6b3480b2c7c08b07729505feab2b2c16661ff6e"
 
 inherit pypi setuptools3 ptest