Explorar el Código

vlc: Add -pthread on riscv

Fixes missing atomic symols during linking e.g.

vlc-3.0.6/src/misc/picture_pool.c:201: undefined reference to `__atomic_fetch_add_2'
collect2: error: ld returned 1 exit status

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj hace 5 años
padre
commit
f2728df71d
Se han modificado 1 ficheros con 2 adiciones y 0 borrados
  1. 2 0
      meta-multimedia/recipes-multimedia/vlc/vlc_3.0.6.bb

+ 2 - 0
meta-multimedia/recipes-multimedia/vlc/vlc_3.0.6.bb

@@ -3,6 +3,8 @@ require ${BPN}.inc
 # work around build failure
 EXTRA_OECONF += " --enable-libxml2=no"
 
+LDFLAGS_append_riscv64 = " -pthread"
+
 SRC_URI += " \
             file://0002-glibc-does-not-provide-strlcpy.patch \
             file://0005-libpostproc-header-check.patch \