Browse Source

python3-humanize: Upgrade 0.5.1 -> 2.4.0

Upgrade to release 2.4.0 and consolidate into a single file.
The year in file LICENCE has been recently updated therefore the
checksum has been changed but it still remains a MIT License.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Leon Anavi 4 years ago
parent
commit
ef7ddd5b28

+ 0 - 14
meta-python/recipes-devtools/python/python-humanize.inc

@@ -1,14 +0,0 @@
-SUMMARY = "Python humanize utilities"
-HOMEPAGE = "http://github.com/jmoiron/humanize"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENCE;md5=d2eff82fc25dd07c919a02465884f02e"
-
-SRC_URI[md5sum] = "e8473d9dc1b220911cac2edd53b1d973"
-SRC_URI[sha256sum] = "a43f57115831ac7c70de098e6ac46ac13be00d69abbf60bdcac251344785bb19"
-
-RDEPENDS_${PN} += "\
-    ${PYTHON_PN}-datetime \
-"
-
-BBCLASSEXTEND = "native nativesdk"

+ 0 - 2
meta-python/recipes-devtools/python/python3-humanize_0.5.1.bb

@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-humanize.inc

+ 20 - 0
meta-python/recipes-devtools/python/python3-humanize_2.4.0.bb

@@ -0,0 +1,20 @@
+SUMMARY = "Python humanize utilities"
+HOMEPAGE = "http://github.com/jmoiron/humanize"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
+
+SRC_URI[md5sum] = "010e86a4196ed6030112e7bc681e7353"
+SRC_URI[sha256sum] = "42ae7d54b398c01bd100847f6cb0fc9e381c21be8ad3f8e2929135e48dbff026"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+    ${PYTHON_PN}-setuptools-scm-native \
+"
+
+RDEPENDS_${PN} += "\
+    ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"