Selaa lähdekoodia

meta-oe: Don't inherit 'features_check' in recipes that don't utilize it

Signed-off-by: Jacob Kroon <jacob.kroon@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Jacob Kroon 3 vuotta sitten
vanhempi
commit
e921a2f251

+ 1 - 1
meta-oe/recipes-connectivity/transmission/transmission_git.bb

@@ -19,7 +19,7 @@ PV = "2.94"
 
 S = "${WORKDIR}/git"
 
-inherit autotools gettext update-rc.d systemd mime-xdg features_check
+inherit autotools gettext update-rc.d systemd mime-xdg
 
 PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \
                  ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"

+ 1 - 1
meta-oe/recipes-extended/fluentbit/fluentbit_1.3.5.bb

@@ -52,7 +52,7 @@ EXTRA_OECMAKE_append_riscv64 = " -DFLB_DEPS='atomic'"
 # DEPENDS += "openssl "
 # EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On "
 
-inherit cmake systemd features_check
+inherit cmake systemd
 
 SYSTEMD_SERVICE_${PN} = "td-agent-bit.service"
 TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"

+ 1 - 1
meta-oe/recipes-support/upower/upower_0.99.11.bb

@@ -10,7 +10,7 @@ SRC_URI = " \
 SRC_URI[md5sum] = "abe6acb617f11f2e8dbd9846fcf86e24"
 SRC_URI[sha256sum] = "64b5ffbfccd5bdb15d925777979a4dbee1a957f9eaeb158dc76175267eddbdef"
 
-inherit autotools pkgconfig gettext gobject-introspection systemd features_check
+inherit autotools pkgconfig gettext gobject-introspection systemd
 
 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
 PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"