Browse Source

dhcp_%.bbappend: fix replaces original key warning

Use ${PN} rather than dhcp to keep align with oe-core to fix:
WARNING: oe-core/meta/recipes-connectivity/dhcp/dhcp_4.3.4.bb: Variable key SYSTEMD_AUTO_ENABLE_${PN}-client (enable) replaces original key SYSTEMD_AUTO_ENABLE_dhcp-client (disable).
WARNING: oe-core/meta/recipes-connectivity/dhcp/dhcp_4.3.4.bb: Variable key SYSTEMD_SERVICE_${PN}-client (dhclient.service) replaces original key SYSTEMD_SERVICE_dhcp-client (dhclient.service).

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Robert Yang 7 years ago
parent
commit
e63aa5b056
1 changed files with 2 additions and 2 deletions
  1. 2 2
      meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend

+ 2 - 2
meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_%.bbappend

@@ -2,8 +2,8 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SYSTEMD_PACKAGES += "dhcp-client"
-SYSTEMD_SERVICE_dhcp-client = "dhclient.service"
-SYSTEMD_AUTO_ENABLE_dhcp-client = "disable"
+SYSTEMD_SERVICE_${PN}-client = "dhclient.service"
+SYSTEMD_AUTO_ENABLE_${PN}-client = "disable"
 
 FILES_${PN}-client += "${systemd_unitdir}/system/dhclient.service"
 RPROVIDES_dhcp-server += "dhcp-server-systemd"