Browse Source

netkit-rsh: inherit update-alternatives

* fixes:
  netkit-rsh-0.17-r0 do_package_qa: QA Issue: netkit-rsh: recipe defines ALTERNATIVE_netkit-rsh-client but doesn't inherit update-alternatives. This might fail during do_rootfs later! [missing-update-alternatives]
  netkit-rsh-0.17-r0 do_package_qa: QA Issue: netkit-rsh: recipe defines ALTERNATIVE_netkit-rsh-server but doesn't inherit update-alternatives. This might fail during do_rootfs later! [missing-update-alternatives]

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Martin Jansa 3 years ago
parent
commit
e48aabf951
1 changed files with 1 additions and 1 deletions
  1. 1 1
      meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb

+ 1 - 1
meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb

@@ -31,7 +31,7 @@ PAM_SRC_URI = "file://rexec.pam \
 "
 SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
 
-inherit pkgconfig
+inherit pkgconfig update-alternatives
 
 CFLAGS += " -D_GNU_SOURCE -Wno-deprecated-declarations"
 LDFLAGS += " -L${STAGING_LIBDIR} -lutil -lcrypt"