Browse Source

uim: Fixed a problem that an immodule.cache is not updated appropriately when uim-gtk2.0 or uim-gtk3 was installed.

pkg_postinst_uim-gtk2.0 is not worked. Plus, uim-gtk3 is not supported.
oe-core has gtk-immodule-cache class for update the immodule.cache.
Modified to use the this class instead of pkg_post_uim-gtk2.0 and added support to uim-gtk3.

Signed-off-by: Yusuke Mitsuki <mickey.happygolucky@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Yusuke Mitsuki 6 years ago
parent
commit
e44af0d743
1 changed files with 2 additions and 5 deletions
  1. 2 5
      meta-oe/recipes-support/uim/uim_1.8.6.bb

+ 2 - 5
meta-oe/recipes-support/uim/uim_1.8.6.bb

@@ -21,7 +21,8 @@ RDEPENDS_uim-anthy = "takao-fonts anthy libanthy0 glibc-utils glibc-gconv-euc-jp
 
 LEAD_SONAME = "libuim.so.1"
 
-inherit autotools pkgconfig gettext qemu
+inherit autotools pkgconfig gettext qemu gtk-immodules-cache
+GTKIMMODULES_PACKAGES = "uim-gtk2.0 uim-gtk3"
 
 EXTRA_OECONF += "--disable-emacs \
     --without-scim \
@@ -120,10 +121,6 @@ pkg_prerm_uim-anthy() {
     fi
 }
 
-pkg_postinst_uim-gtk2.0() {
-    gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
-}
-
 pkg_postinst_uim-skk() {
     if test -n "$D"; then
         ${@qemu_run_binary(d, '$D', '${bindir}/uim-module-manager')} --register skk --path $D${datadir}/uim