Browse Source

fcgi: Update to 2.4.1+

Update to latest from upstream. This adds pkg-config support.
Fix_EOF_not_declared_issue.patch is obsolete, fix is upstream.

Signed-off-by: Adrian Freihofer <adrian.freihofer@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Adrian 6 years ago
parent
commit
d194fe9724

+ 0 - 17
meta-webserver/recipes-support/fcgi/fcgi/Fix_EOF_not_declared_issue.patch

@@ -1,17 +0,0 @@
-Upstream-Status: Pending
-
-Fix EOF not declared issue, following is the error log.
-fcgio.cpp:70:72: error: 'EOF' was not declared in this scope
-              if (FCGX_PutStr(pbase(), plen, this->fcgx) != plen) return EOF;
-
-Signed-off-by: Yang Haibo <b40869@freescale.com>
---- fcgi-ori/libfcgi/fcgio.cpp 2014-07-28 18:01:00.000000000 +0800
-+++ fcgi-2.4.0/libfcgi/fcgio.cpp       2014-07-28 18:01:22.000000000 +0800
-@@ -22,6 +22,7 @@
- #define DLLAPI  __declspec(dllexport)
- #endif
-
-+#include <stdio.h>
- #include <limits.h>
- #include "fcgio.h"
-

+ 2 - 2
meta-webserver/recipes-support/fcgi/fcgi/add_foreign_to_AM_INIT_AUTOMAKE.patch

@@ -10,8 +10,8 @@ Signed-off-by: Yang Haibo <b40869@freescale.com>
  dnl     to configure the system for the local environment.
  
 -AC_INIT
--AM_INIT_AUTOMAKE(fcgi, 2.4.0)
-+AC_INIT([fcgi], [2.4.0])
+-AM_INIT_AUTOMAKE(fcgi, 2.4.1-SNAP-0910052249)
++AC_INIT([fcgi], [2.4.1-SNAP-0910052249])
 +AM_INIT_AUTOMAKE([foreign])
  
  AM_CONFIG_HEADER(fcgi_config.h)

+ 6 - 4
meta-webserver/recipes-support/fcgi/fcgi_2.4.0.bb → meta-webserver/recipes-support/fcgi/fcgi_git.bb

@@ -3,12 +3,14 @@ HOMEPAGE = "http://www.fastcgi.com"
 LICENSE = "OML"
 LIC_FILES_CHKSUM = "file://LICENSE.TERMS;md5=e3aacac3a647af6e7e31f181cda0a06a"
 
-SRC_URI = "http://fossies.org/linux/www/old/${BP}.tar.gz \
-           file://Fix_EOF_not_declared_issue.patch \
+SRCREV = "68100b5b8cb26f04b784778ed19ccef4fe389f57"
+PV = "2.4.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/FastCGI-Archives/fcgi2.git;protocol=https \
            file://add_foreign_to_AM_INIT_AUTOMAKE.patch \
 "
-SRC_URI[md5sum] = "d15060a813b91383a9f3c66faf84867e"
-SRC_URI[sha256sum] = "66fc45c6b36a21bf2fbbb68e90f780cc21a9da1fffbae75e76d2b4402d3f05b9"
+
+S = "${WORKDIR}/git"
 
 inherit autotools