Browse Source

android-tools: split adbd to the separate package

Usually one would install adbd on a device, where adb and mkbootimg are
of little use. Split adbd to the separate package.

Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
lumag 3 years ago
parent
commit
d00a1f363d
1 changed files with 9 additions and 3 deletions
  1. 9 3
      meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb

+ 9 - 3
meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb

@@ -67,7 +67,8 @@ COMPATIBLE_HOST_powerpc64le = "(null)"
 
 inherit systemd
 
-SYSTEMD_SERVICE_${PN} = "android-tools-adbd.service"
+SYSTEMD_PACKAGES = "${PN}-adbd"
+SYSTEMD_SERVICE_${PN}-adbd = "android-tools-adbd.service"
 
 # Find libbsd headers during native builds
 CC_append_class-native = " -I${STAGING_INCDIR}"
@@ -157,11 +158,16 @@ do_install() {
     fi
 }
 
-PACKAGES =+ "${PN}-fstools"
+PACKAGES =+ "${PN}-fstools ${PN}-adbd"
 
-RDEPENDS_${BPN} = "${BPN}-conf"
+RDEPENDS_${BPN}-adbd = "${BPN}-conf"
 RDEPENDS_${BPN}-fstools = "bash"
 
+FILES_${PN}-adbd = "\
+    ${bindir}/adbd \
+    ${systemd_unitdir}/system/android-tools-adbd.service \
+"
+
 FILES_${PN}-fstools = "\
     ${bindir}/ext2simg \
     ${bindir}/ext4fixup \