Browse Source

ace-cloud-editor_git.bb: Add recipe for ace cloud editor

Yocto recipe for Ace-code-editor an open source embeddable code editor written
in JavaScript. It can be easily embedded in any webpage and JavaScript
application.

Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>
Signed-off-by: Bhargava Sreekantappa Gayathri <bhargava.sreekantappa-gayathri@xilinx.com>
Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Sai Hari Chandana Kalluri 5 years ago
parent
commit
c245374faf
1 changed files with 22 additions and 0 deletions
  1. 22 0
      recipes-utils/ace-cloud-editor/ace-cloud-editor_git.bb

+ 22 - 0
recipes-utils/ace-cloud-editor/ace-cloud-editor_git.bb

@@ -0,0 +1,22 @@
+DESCRIPTION = "Ace is a code editor written in JavaScript."
+SUMMARY = "Ace is a code editor written in JavaScript. This repository has only generated files"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=794d11c5219c59c9efa2487c2b4066b2"
+
+SRC_URI = "git://github.com/ajaxorg/ace-builds.git;protocol=https"
+
+PV = "02.07.17+git${SRCPV}"
+SRCREV = "812e2c56aed246931a667f16c28b096e34597016"
+
+FILES_${PN} = "${datadir}/ace-builds"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "rsync-native"
+
+do_install () {
+    install -d ${D}/${datadir}/ace-builds/src-noconflict
+    rsync -r --exclude=".*" ${S}/src-noconflict/* ${D}/${datadir}/ace-builds/src-noconflict
+}
+