Browse Source

st: Use update alternatives

These files are also provided by ncurses so learn to co-habit

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
ad7e4b2fd0
1 changed files with 10 additions and 0 deletions
  1. 10 0
      meta-oe/recipes-graphics/suckless/st_0.8.4.bb

+ 10 - 0
meta-oe/recipes-graphics/suckless/st_0.8.4.bb

@@ -23,3 +23,13 @@ do_install() {
 FILES_${PN} += " \
     ${datadir}/terminfo \
 "
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "50"
+
+ALTERNATIVE_${PN} = "st st-256color"
+
+ALTERNATIVE_LINK_NAME[st] = "${datadir}/terminfo/s/st"
+
+ALTERNATIVE_LINK_NAME[st-256color] = "${datadir}/terminfo/s/st-256color"