Browse Source

dumb-init: New recipe

This is a really simple init replacement for lightweight container images.

See https://engineeringblog.yelp.com/2016/01/dumb-init-an-init-for-docker.html
for more info.

Signed-off-by: Paul Barker <pbarker@toganlabs.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Paul Barker 6 years ago
parent
commit
a72fc487da
1 changed files with 15 additions and 0 deletions
  1. 15 0
      meta-oe/recipes-extended/dumb-init/dumb-init_1.2.0.bb

+ 15 - 0
meta-oe/recipes-extended/dumb-init/dumb-init_1.2.0.bb

@@ -0,0 +1,15 @@
+SUMMARY = "Simple wrapper script which proxies signals to a child"
+HOMEPAGE = "https://github.com/Yelp/dumb-init/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5940d39995ea6857d01b8227109c2e9c"
+
+SRC_URI = "https://github.com/Yelp/dumb-init/archive/v${PV}.tar.gz"
+SRC_URI[md5sum] = "4eb7f43d7823686723ff7ac1bad097cb"
+SRC_URI[sha256sum] = "74486997321bd939cad2ee6af030f481d39751bc9aa0ece84ed55f864e309a3f"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS} ${LDFLAGS}'"
+
+do_install() {
+    install -d ${D}${base_sbindir}
+    install ${S}/dumb-init ${D}${base_sbindir}/
+}