瀏覽代碼

flatbuffers: add python3 support

Add package flatbuffers-python3 to install python3 scripts

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Hongxu Jia 3 年之前
父節點
當前提交
9df2c2daa8
共有 1 個文件被更改,包括 11 次插入1 次删除
  1. 11 1
      meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb

+ 11 - 1
meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.12.0.bb

@@ -3,9 +3,12 @@ HOMEPAGE = "https://github.com/google/flatbuffers"
 SECTION = "console/tools"
 LICENSE = "Apache-2.0"
 
-PACKAGE_BEFORE_PN = "${PN}-compiler"
+inherit python3-dir
+
+PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-${PYTHON_PN}"
 
 RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-${PYTHON_PN} = "${PN}"
 RDEPENDS_${PN}-dev += "${PN}-compiler"
 
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
@@ -28,6 +31,13 @@ inherit cmake
 
 S = "${WORKDIR}/git"
 
+do_install_append() {
+    install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+    cp -rf ${S}/python/flatbuffers ${D}${PYTHON_SITEPACKAGES_DIR}
+}
+
 FILES_${PN}-compiler = "${bindir}"
 
+FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
+
 BBCLASSEXTEND = "native nativesdk"