Sfoglia il codice sorgente

kernel-selftest: Disable vm tests for mips/arm

Include lib and kernel subdirs as vm tests need headers from it in 5.8+
(test_hmm_uapi.h) see [1]

It now uses tests which are not compatible on arm starting with 5.8+

[1] https://lkml.org/lkml/2020/4/22/1654

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 anni fa
parent
commit
9949d2714d

+ 8 - 4
meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb

@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
 
 LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
 
-DEPENDS = "rsync-native llvm-native libhugetlbfs"
+DEPENDS = "rsync-native llvm-native"
 
 # for musl libc
 SRC_URI_append_libc-musl = "\
@@ -20,15 +20,16 @@ SRC_URI += "file://run-ptest \
 # if you have older kernel than that you need to remove it from PACKAGECONFIG
 PACKAGECONFIG ??= "bpf firmware vm"
 PACKAGECONFIG_remove_x86 = "bpf"
-PACKAGECONFIG_remove_arm = "bpf"
+PACKAGECONFIG_remove_arm = "bpf vm"
 # host ptrace.h is used to compile BPF target but mips ptrace.h is needed
 # progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs'
 # m = PT_REGS_RC(ctx);
-PACKAGECONFIG_remove_qemumips = "bpf"
+# vm tests need libhugetlbfs starting 5.8+ (https://lkml.org/lkml/2020/4/22/1654)
+PACKAGECONFIG_remove_qemumips = "bpf vm"
 
 PACKAGECONFIG[bpf] = ",,elfutils libcap libcap-ng rsync-native,"
 PACKAGECONFIG[firmware] = ",,libcap, bash"
-PACKAGECONFIG[vm] = ",,libcap,libgcc bash"
+PACKAGECONFIG[vm] = ",,libcap libhugetlbfs,libgcc bash"
 
 do_patch[depends] += "virtual/kernel:do_shared_workdir"
 
@@ -49,10 +50,13 @@ EXTRA_OEMAKE = '\
     AR="${AR}" \
     LD="${LD}" \
     DESTDIR="${D}" \
+    MACHINE="${ARCH}" \
 '
 
 KERNEL_SELFTEST_SRC ?= "Makefile \
                         include \
+                        kernel \
+                        lib \
                         tools \
                         scripts \
                         arch \