Browse Source

netdata: Link with libpthread

Fixes
global_statistics.c:90: undefined reference to `__atomic_fetch_add_2'
| collect2: error: ld returned 1 exit status

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 5 years ago
parent
commit
8ee106097d
1 changed files with 2 additions and 0 deletions
  1. 2 0
      meta-webserver/recipes-webadmin/netdata/netdata_git.bb

+ 2 - 0
meta-webserver/recipes-webadmin/netdata/netdata_git.bb

@@ -27,6 +27,8 @@ DEPENDS += "zlib util-linux"
 
 inherit pkgconfig autotools useradd systemd
 
+LDFLAGS += "-pthread"
+
 #systemd
 SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE_${PN} = "netdata.service"