ソースを参照

stressapptest: Use git SHA instead of git archive

git archives get regenerated randomly so lets use git fetcher instead

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 年 前
コミット
8b5ebbf6e6

+ 4 - 5
meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb

@@ -9,14 +9,13 @@ SECTION = "benchmark"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://COPYING;md5=55ea9d559f985fb4834317d8ed6b9e58"
 
-SRC_URI = "https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz \
+SRCREV = "fb72e5e5f0879231f38e0e826a98a6ca2d1ca38e"
+
+SRC_URI = "git://github.com/stressapptest/stressapptest \
            file://libcplusplus-compat.patch \
            file://read_sysfs_for_cachesize.patch \
           "
 
-SRC_URI[md5sum] = "d3a526c174c049dd7a1068dc74a62be2"
-SRC_URI[sha256sum] = "2ba470587ad4f6ae92057d427c3a2a2756e5f10bd25cd91e62eaef55a40b30a1"
-
-S = "${WORKDIR}/${PN}-${PV}"
+S = "${WORKDIR}/git"
 
 inherit autotools