Browse Source

zbar: Switch to github and update to latest

License-Update: Year changed [1]

There has been releases after 0.10 and carries fixes that helps
compiling with newer compilers

Disable Werror, since newer compilers detect more warnings

[1] https://github.com/ZBar/ZBar/commit/d08189db4c4f86d1e0addd51db3142ec5b40f98c

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 years ago
parent
commit
87d77fd45e

+ 10 - 6
meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch

@@ -14,8 +14,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
  configure.ac | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/configure.ac b/configure.ac
-index 56d3dd0..9f85fd7 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -3,7 +3,7 @@ AC_PREREQ([2.61])
@@ -23,10 +21,16 @@ index 56d3dd0..9f85fd7 100644
  AC_CONFIG_AUX_DIR(config)
  AC_CONFIG_MACRO_DIR(config)
 -AM_INIT_AUTOMAKE([1.10 -Wall -Werror foreign subdir-objects std-options dist-bzip2])
-+AM_INIT_AUTOMAKE([1.10 -Wall -Werror -Wno-portability foreign subdir-objects std-options dist-bzip2])
++AM_INIT_AUTOMAKE([1.10 -Wall -Wno-error foreign subdir-objects std-options dist-bzip2])
  AC_CONFIG_HEADERS([include/config.h])
  AC_CONFIG_SRCDIR(zbar/scanner.c)
  LT_PREREQ([2.2])
--- 
-2.10.2
-
+@@ -47,7 +47,7 @@ AC_DEFINE_UNQUOTED([LIB_VERSION_REVISION
+   [Library revision])
+ 
+ AM_CPPFLAGS="-I$srcdir/include"
+-AM_CFLAGS="-Wall -Wno-parentheses -Werror"
++AM_CFLAGS="-Wall -Wno-parentheses"
+ AM_CXXFLAGS="$AM_CFLAGS"
+ AC_SUBST([AM_CPPFLAGS])
+ AC_SUBST([AM_CFLAGS])

+ 0 - 51
meta-oe/recipes-support/zbar/zbar/0001-undefine-__va_arg_pack.patch

@@ -1,51 +0,0 @@
-From f842872244219d9881fbec77054702412b1e16f8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 2 Dec 2016 16:41:27 -0800
-Subject: [PATCH] undefine __va_arg_pack
-
-dprintf() is also a libc function. This fixes
-the compile errors
-
-/usr/include/bits/stdio2.h:140:1: error: expected identifier or '(' before '{' token
-|  {
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- zbar/debug.h | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/zbar/debug.h b/zbar/debug.h
-index 482ca8d..68948f6 100644
---- a/zbar/debug.h
-+++ b/zbar/debug.h
-@@ -23,6 +23,7 @@
- 
- /* varargs variations on compile time debug spew */
- 
-+#undef __va_arg_pack
- #ifndef DEBUG_LEVEL
- 
- # ifdef __GNUC__
-@@ -36,15 +37,14 @@
- #else
- 
- # include <stdio.h>
--
- # ifdef __GNUC__
--#  define dprintf(level, args...) \
-+#  define dprintf(level, format, args...) \
-     if((level) <= DEBUG_LEVEL)    \
--        fprintf(stderr, args)
-+        fprintf(stderr, format, args)
- # else
--#  define dprintf(level, ...)     \
-+#  define dprintf(level, format, ...)     \
-     if((level) <= DEBUG_LEVEL)    \
--        fprintf(stderr, __VA_ARGS__)
-+        fprintf(stderr, format, __VA_ARGS__)
- # endif
- 
- #endif /* DEBUG_LEVEL */
--- 
-2.10.2
-

+ 10 - 7
meta-oe/recipes-support/zbar/zbar_0.10.bb → meta-oe/recipes-support/zbar/zbar_git.bb

@@ -4,15 +4,16 @@ LICENSE = "LGPL-2.1"
 
 DEPENDS = "pkgconfig intltool-native libpng jpeg"
 
-LIC_FILES_CHKSUM = "file://COPYING;md5=42bafded1b380c6fefbeb6c5cd5448d9"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4015840237ca7f0175cd626f78714ca8"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2 \
-           file://0001-undefine-__va_arg_pack.patch \
+PV = "0.10+git${SRCPV}"
+
+#  iPhoneSDK-1.3.1 tag
+SRCREV = "67003d2a985b5f9627bee2d8e3e0b26d0c474b57"
+SRC_URI = "git://github.com/ZBar/Zbar \
            file://0001-make-relies-GNU-extentions.patch \
 "
-
-SRC_URI[md5sum] = "0fd61eb590ac1bab62a77913c8b086a5"
-SRC_URI[sha256sum] = "234efb39dbbe5cef4189cc76f37afbe3cfcfb45ae52493bfe8e191318bdbadc6"
+S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig
 
@@ -20,7 +21,9 @@ PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
 
 PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp"
 
-EXTRA_OECONF = " --without-imagemagick --without-qt --without-python --disable-video --without-gtk"
+EXTRA_OECONF = "--without-imagemagick --without-qt --without-python --disable-video --without-gtk"
+
+CPPFLAGS += "-Wno-error"
 
 do_install_append() {
     #remove usr/bin if empty