Browse Source

pidgin: Use python3 during build

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 years ago
parent
commit
84f890bc14

+ 20 - 0
meta-oe/recipes-support/pidgin/pidgin/use_py3.patch

@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1488,7 +1488,7 @@ AC_ARG_WITH([python],
+ 
+ if test "x$enable_dbus" = "xyes" || test "x$enable_consoleui" = "xyes" ; then
+ 	if test -z "$PYTHON" -o "x$PYTHON" = "xyes"; then
+-		AC_PATH_PROG([PYTHON], [python], [no])
++		AC_PATH_PROG([PYTHON], [python3], [no])
+ 	fi
+ 
+ 	if test x"$PYTHON" = x"no" ; then
+@@ -1568,7 +1568,7 @@ dnl Check for Python headers (currently
+ dnl (Thanks to XChat)
+ if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then
+         AC_MSG_CHECKING(for Python compile flags)
+-        PKG_CHECK_MODULES(PY, python, [
++        PKG_CHECK_MODULES(PY, python3, [
+                 AC_SUBST(PY_CFLAGS)
+                 AC_SUBST(PY_LIBS)
+         ], [

+ 1 - 0
meta-oe/recipes-support/pidgin/pidgin_2.13.0.bb

@@ -11,6 +11,7 @@ SRC_URI = "\
     file://sanitize-configure.ac.patch \
     file://purple-OE-branding-25.patch \
     file://pidgin-cross-python-265.patch \
+    file://use_py3.patch \
 "
 
 SRC_URI[md5sum] = "423403494fe1951e47cc75231f743bb0"