Bladeren bron

recipes: Exclude non-buildable recipes from world for musl build

These recipes need to be fixed for musl, until they are needed
on musl lets remove them from world builds

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 5 jaren geleden
bovenliggende
commit
7e0fa293b7

+ 3 - 0
meta-networking/recipes-connectivity/rdist/rdist_6.1.5.bb

@@ -38,3 +38,6 @@ DEPENDS = "bison-native"
 inherit autotools-brokensep
 
 EXTRA_OEMAKE = "BIN_GROUP=root MAN_GROUP=root RDIST_MODE=755 RDISTD_MODE=755 MAN_MODE=644"
+
+# http://errors.yoctoproject.org/Errors/Details/186972/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 2 - 0
meta-networking/recipes-daemons/opensaf/opensaf_5.18.04.bb

@@ -70,3 +70,5 @@ INSANE_SKIP_${PN} = "dev-so"
 
 RDEPENDS_${PN} += "bash python"
 
+# http://errors.yoctoproject.org/Errors/Details/186970/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 3 - 0
meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb

@@ -100,3 +100,6 @@ RPROVIDES_${PN}-server = "rshd"
 
 RDEPENDS_${PN}-server = "xinetd"
 RDEPENDS_${PN}-server += "tcp-wrappers"
+
+# http://errors.yoctoproject.org/Errors/Details/186963/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 3 - 0
meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb

@@ -73,3 +73,6 @@ FILES_${PN}-dbg = "${prefix}/src/debug \
             ${bindir}/.debug ${sbindir}/.debug"
 
 RDEPENDS_${PN}-server = "tcp-wrappers xinetd rpcbind"
+
+# http://errors.yoctoproject.org/Errors/Details/186962/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 3 - 0
meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb

@@ -59,3 +59,6 @@ ALTERNATIVE_LINK_NAME[telnet] = "${bindir}/telnet"
 SRC_URI[md5sum] = "d6beabaaf53fe6e382c42ce3faa05a36"
 SRC_URI[sha256sum] = "9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00"
 FILES_${PN} += "${sbindir}/in.* ${libdir}/* ${sysconfdir}/xinetd.d/*"
+
+# http://errors.yoctoproject.org/Errors/Details/186954/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 2 - 0
meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb

@@ -30,3 +30,5 @@ do_configure() {
 do_install() {
     oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
 }
+# http://errors.yoctoproject.org/Errors/Details/186959/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

File diff suppressed because it is too large
+ 0 - 0
meta-oe/recipes-kernel/crash/crash_7.2.3.bb


+ 3 - 0
meta-oe/recipes-kernel/minicoredumper/minicoredumper_2.0.0.bb

@@ -42,3 +42,6 @@ do_install_append() {
     sed -i -e s:/usr/bin/minicoredumper:${sbindir}/minicoredumper:g ${D}${sysconfdir}/init.d/minicoredumper
     sed -i -e s:/usr/bin/minicoredumper:${sbindir}/minicoredumper:g ${D}${systemd_system_unitdir}/minicoredumper.service
 }
+
+# http://errors.yoctoproject.org/Errors/Details/186966/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 3 - 0
meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.6.bb

@@ -41,3 +41,6 @@ do_configure_prepend () {
     touch NEWS README AUTHORS ChangeLog
     sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in
 }
+
+# http://errors.yoctoproject.org/Errors/Details/186961/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

+ 3 - 0
meta-oe/recipes-test/pm-qa/pm-qa_git.bb

@@ -63,3 +63,6 @@ do_install () {
     done
 }
 RDEPENDS_${PN} +="bash"
+
+# http://errors.yoctoproject.org/Errors/Details/186956/
+EXCLUDE_FROM_WORLD_libc-musl = "1"

Some files were not shown because too many files changed in this diff