Browse Source

canutils: Use update-alternatives

canutils provides applications which conflict with can-utils recipe.
update-alternatives helps fix this when both are installed

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
7de0bbbbaa

+ 5 - 1
meta-oe/recipes-extended/socketcan/can-utils_git.bb

@@ -12,4 +12,8 @@ PV = "2020.02.04"
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-alternatives
+
+ALTERNATIVE_${PN} = "candump cansend"
+ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
+ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"

+ 7 - 0
meta-oe/recipes-extended/socketcan/canutils_4.0.6.bb

@@ -12,9 +12,16 @@ SRC_URI = "git://git.pengutronix.de/git/tools/canutils.git;protocol=git \
     file://0001-canutils-candump-Add-error-frame-s-handling.patch \
 "
 
+inherit update-alternatives
+
 S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig
 
 # Busybox ip doesn't support can interface configuration, use the real thing
 RDEPENDS_${PN} += "iproute2"
+
+ALTERNATIVE_PRIORITY = "90"
+ALTERNATIVE_${PN} = "candump cansend"
+ALTERNATIVE_LINK_NAME[candump] = "${bindir}/candump"
+ALTERNATIVE_LINK_NAME[cansend] = "${bindir}/cansend"