Переглянути джерело

rsyslog: fix wrong option of PACKAGECONFIG[valgrind]

The source configure.ac shows:
--enable-valgrind: Enable somes special code that rsyslog core developers
                   consider useful for testing.Do NOT use if you don't
                   exactly know what you are doing, except if told so
                   by rsyslog developers.
                   NOT to be used by distro maintainers for building regular
                   packages.

--without-valgrind-testbench:
                   Don't use valgrind in testbench

PACKAGECONFIG[valgrind] should use '--without-valgrind-testbench'
And after this fix, the code which removes the valgrind depended
ptest cases for arm,mips is no longer needed.

Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Haiqing Bai 3 роки тому
батько
коміт
7a0edf425e
1 змінених файлів з 1 додано та 7 видалено
  1. 1 7
      meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb

+ 1 - 7
meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb

@@ -76,7 +76,7 @@ PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
 PACKAGECONFIG[postgresql] = "--enable-pgsql,--disable-pgsql,postgresql,"
 PACKAGECONFIG[libdbi] = "--enable-libdbi,--disable-libdbi,libdbi,"
 PACKAGECONFIG[mail] = "--enable-mail,--disable-mail,,"
-PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
+PACKAGECONFIG[valgrind] = ",--without-valgrind-testbench,valgrind,"
 
 do_configure_prepend() {
     sed -i -e 's|python |python3 |g' ${S}/tests/*.sh
@@ -106,12 +106,6 @@ do_install_ptest() {
     # fix the abs_top_builddir
     sed -i 's,^\(abs_top_builddir = \).*,\1${PTEST_PATH}/,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
 
-    # valgrind is not compatible with arm and mips,
-    # so remove related test cases if there is no valgrind.
-    if [ x${VALGRIND} = x ]; then
-        sed -i '/udp-msgreduc-/d' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
-    fi
-
     # install test-driver
     install -m 644 ${S}/test-driver ${D}${PTEST_PATH}