Browse Source

fontforge: explicitly depend on gettext-native

* fixes:
  Making all in po
  make[2]: Entering directory
  `TOPDIR/BUILD/work/x86_64-linux/fontforge-native/20170731-r0/build/po'
  msgfmt --check --output-file=ca.mo ../../git/po/ca.po
  msgfmt --check --output-file=el.mo ../../git/po/el.po
  msgfmt --check --output-file=es.mo ../../git/po/es.po
  msgfmt --check --output-file=it.mo ../../git/po/it.po
  /bin/bash: msgfmt: command not found
  /bin/bash: msgfmt: command not found
  /bin/bash: msgfmt: command not found
  /bin/bash: msgfmt: command not found
  make[2]: *** [ca.mo] Error 127
  make[2]: *** Waiting for unfinished jobs....
  make[2]: *** [el.mo] Error 127
  make[2]: *** [es.mo] Error 127
  make[2]: *** [it.mo] Error 127
  make[2]: Leaving directory
  `TOPDIR/BUILD/work/x86_64-linux/fontforge-native/20170731-r0/build/po'

* as Ross explained:
  needs explicit dependency on gettext-native
  native disables NLS so just has gettext-minimal-native in the depends

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Martin Jansa 6 years ago
parent
commit
6f536298c1
1 changed files with 1 additions and 1 deletions
  1. 1 1
      meta-oe/recipes-graphics/fontforge/fontforge_20170731.bb

+ 1 - 1
meta-oe/recipes-graphics/fontforge/fontforge_20170731.bb

@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = " \
     file://LICENSE;md5=3f922b42ed0033fa0fd4cd3268f6429c \
 "
 
-DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gnulib"
+DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gnulib gettext-native"
 DEPENDS_append_class-target = " libxi"
 
 inherit autotools pkgconfig pythonnative distro_features_check gettext