Browse Source

dialog: Turn X11 support into a packageconfig option

Enable it only if x11 is in distro features

Ensure patch to X includes/libs is pointing into sysroot otherwise it
starts to poke at build systems includes/libs dirs

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
6bcbc0364b
1 changed files with 4 additions and 0 deletions
  1. 4 0
      meta-oe/recipes-extended/dialog/dialog_1.3-20200327.bb

+ 4 - 0
meta-oe/recipes-extended/dialog/dialog_1.3-20200327.bb

@@ -18,6 +18,10 @@ S = "${WORKDIR}/dialog-${PV}"
 
 inherit autotools-brokensep pkgconfig
 
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
+
+PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
+
 EXTRA_OECONF = "--with-ncurses \
                 --disable-rpath-hack"