Browse Source

freeglut: Use -fcommon always

This package does not compile with -fno-common yet

errors out like
| /mnt/b/yoe/master/build/tmp/work/armv7vet2hf-neon-yoe-linux-musleabi/freeglut/3.2.1-r0/recipe-sysroot-native/usr/bin/arm-yoe-linux-musleabi/arm-yoe-linux-musleabi-ld: CMakeFiles/freeglut.dir/src/fg_gl2.c.o:/usr/src/debug/freeglut/3.2.1-
r0/freeglut-3.2.1/src/fg_gl2.h:72: multiple definition of `fghBindBuffer'; CMakeFiles/freeglut.dir/src/fg_geometry.c.o:/usr/src/debug/freeglut/3.2.1-r0/freeglut-3.2.1/src/fg_gl2.h:72: first defined here

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
6b3e7fe997
1 changed files with 3 additions and 0 deletions
  1. 3 0
      meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb

+ 3 - 0
meta-oe/recipes-graphics/freeglut/freeglut_3.2.1.bb

@@ -12,6 +12,9 @@ inherit cmake features_check
 # depends on virtual/libx11, virtual/libgl
 REQUIRED_DISTRO_FEATURES = "x11 opengl"
 
+# Do not use -fno-common, check back when upgrading to new version it might not be needed
+CFLAGS += "-fcommon"
+
 PROVIDES += "mesa-glut"
 
 DEPENDS = "virtual/libx11 libxmu libxi virtual/libgl libglu libxrandr"