Bladeren bron

uim: Add patch to fix -fno-common link error

This is unearthed by gcc10 like below

| /mnt/b/yoe/master/build/tmp/hosttools/ld: .libs/gcroots.o:(.bss+0x0): multiple definition of `GCROOTS_jmp_buf'; .libs/mark.o:(.bss+0x0): first defined here
| /mnt/b/yoe/master/build/tmp/hosttools/ld: .libs/mach_dep.o:(.bss+0x0): multiple definition of `GCROOTS_jmp_buf'; .libs/mark.o:(.bss+0x0): first defined here
| collect2: error: ld returned 1 exit status

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 jaren geleden
bovenliggende
commit
5c6f679704

+ 15 - 0
meta-oe/recipes-support/uim/uim/JMP_BUF_GC_jmp_buf.patch

@@ -0,0 +1,15 @@
+Fix error pointed out by gcc10
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/sigscheme/libgcroots/include/private/gc_priv.h
++++ b/sigscheme/libgcroots/include/private/gc_priv.h
+@@ -2026,7 +2026,7 @@ void GC_err_puts(const char *s);
+ 
+ # if defined(NEED_FIND_LIMIT) || \
+      defined(USE_PROC_FOR_LIBRARIES) && defined(THREADS)
+-JMP_BUF GC_jmp_buf;
++extern JMP_BUF GC_jmp_buf;
+ 
+ /* Set up a handler for address faults which will longjmp to	*/
+ /* GC_jmp_buf;							*/

+ 1 - 0
meta-oe/recipes-support/uim/uim_1.8.8.bb

@@ -6,6 +6,7 @@ SECTION = "inputmethods"
 
 SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2 \
     file://0001-Fix-to-set-libedit-path-from-configure-option-proper.patch \
+    file://JMP_BUF_GC_jmp_buf.patch \
 "
 SRC_URI_append_class-target = "\
     file://uim-module-manager.patch \