Browse Source

libdbus-c++: Add -pthread to linker flags

It uses symbols from libpthread e.g. pthread_mutexattr_init and pthread_mutexattr_settype
but does not link with pthreads, gold is strict about it and calls out with an error

../src/.libs/libdbus-c++-1.so: error: undefined reference to 'pthread_mutexattr_init'
../src/.libs/libdbus-c++-1.so: error: undefined reference to 'pthread_mutexattr_settype'

Therefore correct the linker cmdline

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Khem Raj 7 years ago
parent
commit
592e9f26cc
1 changed files with 1 additions and 0 deletions
  1. 1 0
      meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb

+ 1 - 0
meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb

@@ -21,6 +21,7 @@ SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385
 inherit autotools pkgconfig
 
 EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
+LDFLAGS += "-pthread"
 
 PACKAGE_BEFORE_PN = "${PN}-tools"