Ver código fonte

packagegroup-meta-perl: Update to represent latest recipes

Add packagegroup-meta-perl-ptest to PROVIDES

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 anos atrás
pai
commit
58e8d5dd58

+ 76 - 26
meta-perl/recipes-perl/packagegroups/packagegroup-meta-perl.bb

@@ -3,40 +3,87 @@ SUMMARY = "Meta-perl packagegroup"
 inherit packagegroup
 
 PROVIDES = "${PACKAGES}"
-PACKAGES = ' \
+PACKAGES = "\
     packagegroup-meta-perl \
     packagegroup-meta-perl-extended \
-'
+    ${@bb.utils.contains("DISTRO_FEATURES", "ptest", "packagegroup-meta-perl-ptest-packages", "", d)} \
+"
 
 RDEPENDS_packagegroup-meta-perl = "\
-    libproc-waitstat-perl libmoo-perl libterm-readkey-perl \
-    libunicode-linebreak-perl libcurses-perl libmime-types-perl \
-    libmime-charset-perl libio-socket-ssl-perl libio-stringy-perl \
-    libtext-iconv-perl libtext-charwidth-perl libtext-diff-perl \
-    libtext-wrapi18n-perl liblocale-gettext-perl libdata-hexdump-perl \
-    libextutils-installpaths-perl libextutils-helpers-perl libextutils-parsexs-perl \
-    libextutils-config-perl libextutils-cppguess-perl libimport-into-perl \
-    libcrypt-openssl-rsa-perl libcrypt-openssl-guess-perl libcrypt-openssl-random-perl \
-    libxml-sax-writer-perl libxml-libxml-perl libxml-filter-buffertext-perl \
     adduser \
-    libauthen-sasl-perl libnet-ldap-perl libnet-dns-perl \
-    libnet-dns-sec-perl libnet-libidn-perl libnet-ssleay-perl \
-    libnet-telnet-perl libdevel-globaldestruction-perl libipc-signal-perl \
-    librole-tiny-perl libencode-perl libencode-locale-perl \
-    libfile-slurp-perl libcapture-tiny-perl \
+    libalgorithm-diff-perl \
+    libauthen-sasl-perl \
+    libauthen-radius-perl \
+    libcapture-tiny-perl \
+    libcgi-perl \
+    libdbd-sqlite-perl \
+    libclass-method-modifiers-perl \
+    libdigest-hmac-perl \
+    libdigest-sha1-perl \
+    libconfig-autoconf-perl \
+    libcrypt-openssl-guess-perl \
+    libcrypt-openssl-random-perl \
+    libcrypt-openssl-rsa-perl \
+    libhtml-parser-perl \
+    libhtml-tree-perl \
+    libhtml-tagset-perl \
+    libimport-into-perl \
+    libio-socket-ssl-perl \
+    libio-stringy-perl \
+    libipc-signal-perl \
+    libcurses-perl \
+    libmime-charset-perl \
+    libmime-types-perl \
+    libmodule-pluggable-perl \
+    libmodule-runtime-perl \
+    libmodule-build-tiny-perl \
+    libdata-hexdump-perl \
+    libnet-dns-perl \
+    libnet-libidn-perl \
+    libnet-dns-sec-perl \
+    libnet-ldap-perl \
+    libnet-ssleay-perl \
+    libnet-telnet-perl \
+    libproc-waitstat-perl \
+    libdevel-globaldestruction-perl \
+    libenv-perl \
+    libfile-slurp-perl \
+    libfile-slurper-perl \
+    libtext-iconv-perl \
+    libtext-diff-perl \
+    libtext-charwidth-perl \
+    libtext-wrapi18n-perl \
+    libxml-libxml-perl \
+    libxml-filter-buffertext-perl \
+    libxml-sax-writer-perl \
+    libextutils-config-perl \
+    libextutils-cppguess-perl \
+    libextutils-helpers-perl \
+    libextutils-installpaths-perl \
+    libextutils-parsexs-perl \
+    liblocale-gettext-perl \
+    libmoo-perl \
+    librole-tiny-perl \
+    libunix-statgrab \
+    libstrictures-perl \
+    libsub-exporter-progressive-perl \
+    libsub-uplevel-perl \
+    libterm-readkey-perl \
+    libtest-deep-perl \
+    libtest-harness-perl \
+    libtest-nowarnings-perl \
+    libtest-warn-perl \
+    libtest-warnings-perl \
+    libunicode-linebreak-perl \
     po4a \
-    libstrictures-perl libtest-harness-perl libsub-exporter-progressive-perl \
-    libclass-method-modifiers-perl libhtml-parser-perl libhtml-tree-perl \
-    libmodule-pluggable-perl libmodule-build-perl libmodule-runtime-perl \
-    libmodule-build-tiny-perl libcgi-perl libalgorithm-diff-perl \
-    libdbd-sqlite-perl libdigest-sha1-perl libdigest-hmac-perl \
-    " 
+"
 
 RDEPENDS_packagegroup-meta-perl-extended = "\
-    logcheck mime-construct \
-    "
+    logcheck \
+    mime-construct \
+"
 
-RDEPENDS_packagegroup-meta-perl-ptest = "\
+RDEPENDS_packagegroup-meta-perl-ptest-packages = "\
     libmime-types-perl-ptest \
     libio-socket-ssl-perl-ptest \
     libdata-hexdump-perl-ptest \
@@ -47,6 +94,9 @@ RDEPENDS_packagegroup-meta-perl-ptest = "\
     libtest-harness-perl-ptest \
     libdigest-sha1-perl-ptest \
     libdigest-hmac-perl-ptest \
-    "
+"
 
 EXCLUDE_FROM_WORLD = "1"
+
+# perl-module-encode is preferred over libencode-perl
+# libencode-locale-perl depends on libencode-perl