Explorar el Código

python3-matplotlib: Disable LTO on mips/clang

It needs lld with lto and lld does not yet support gnu_hash for mips

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj hace 3 años
padre
commit
566fe41c1c

+ 2 - 0
meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb

@@ -26,6 +26,7 @@ inherit pypi setuptools3 pkgconfig
 
 # LTO with clang needs lld
 LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
+LDFLAGS_remove_toolchain-clang_mips = "-fuse-ld=lld"
 
 RDEPENDS_${PN} = "\
     freetype \
@@ -40,6 +41,7 @@ RDEPENDS_${PN} = "\
 
 ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
 ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
+ENABLELTO_toolchain-clang_mips = "echo enable_lto = False >> ${S}/setup.cfg"
 do_compile_prepend() {
     echo [libs] > ${S}/setup.cfg
     echo system_freetype = true >> ${S}/setup.cfg