Bladeren bron

libharu: Fix the packaging bug

The following error will occur when multilib is enabled:
ERROR: libharu-2.3.0-r0 do_package: QA Issue: libharu: Files/directories were installed but not shipped in any package:
  /usr/lib
  /usr/lib/libhpdfs.a
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
libharu: 2 installed and not shipped files. [installed-vs-shipped]
ERROR: libharu-2.3.0-r0 do_package: Fatal QA errors found, failing task.

Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
zangrc 3 jaren geleden
bovenliggende
commit
53a143eeb7

+ 30 - 0
meta-oe/recipes-support/libharu/libharu/0001-Install-static-lib-into-var-libdir-rather-than-hardc.patch

@@ -0,0 +1,30 @@
+From 9341ac4f6ae38efe95dfd188105a9ea30941ccf6 Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@cn.fujitsu.com>
+Date: Wed, 18 Nov 2020 23:09:51 +0900
+Subject: [PATCH] Install static lib into var-libdir rather than hardcod lib.
+
+Lei Maohui <leimaohui@cn.fujitsu.com>
+
+Upstream-Status: Pending
+---
+ src/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 249916c..fb06ea3 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -75,8 +75,8 @@ if(LIBHPDF_STATIC)
+   target_link_libraries(${LIBHPDF_NAME_STATIC} ${ADDITIONAL_LIBRARIES})
+   install(
+     TARGETS ${LIBHPDF_NAME_STATIC}
+-    ARCHIVE DESTINATION lib
+-    LIBRARY DESTINATION lib
++    ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
++    LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+     RUNTIME DESTINATION bin
+   )
+   if(WIN32 AND NOT CYGWIN)
+-- 
+2.25.1
+

+ 1 - 0
meta-oe/recipes-support/libharu/libharu_2.3.0.bb

@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://README;md5=3ee6bc1f64d9cc7907f44840c8e50cb1"
 
 SRC_URI = "git://github.com/libharu/libharu.git;branch=2_3 \
            file://libharu-RELEASE_2_3_0_cmake.patch \
+           file://0001-Install-static-lib-into-var-libdir-rather-than-hardc.patch \
 	   "
 
 SRCREV = "4ae1d5f4c84459f130bf1b1ef4c5c330af8eca5d"