Browse Source

python3-jsonrpcserver: allow to use as non-root

This version has some file system permission issues, all
the files are readable by the owner only (in the archive
from pypi.org). Given all files in the target file system
will ultimately be owned by root, this means that this
package can only be used by root.

Fix the permissions, and hopefully the next version will
have the archive fixed. The version has been hard-coded
on purpose here so as to remind us to double-check if
the _append() is still needed after a version upgrade.

Signed-off-by: André Draszik <git@andred.net>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
André Draszik 4 years ago
parent
commit
4f3c9ca9b0

+ 4 - 0
meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb

@@ -21,3 +21,7 @@ RDEPENDS_${PN} += "\
 "
 
 BBCLASSEXTEND = "native nativesdk"
+
+do_install_append() {
+    chmod 0644 ${D}${PYTHON_SITEPACKAGES_DIR}/jsonrpcserver-4.1.0-py3.7.egg-info/*
+}