Quellcode durchsuchen

netkit-rsh: properly append PACKAGECONFIG

As ??= assignment will be overwritten by += in any case,
one can't define a default of PACKAGECONFIG in this recipe.
Using _append instead mitigates chances of accidental overwriting
the default

Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Konrad Weihmann vor 4 Jahren
Ursprung
Commit
4cca3eff38
1 geänderte Dateien mit 1 neuen und 1 gelöschten Zeilen
  1. 1 1
      meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb

+ 1 - 1
meta-networking/recipes-netkit/netkit-rsh/netkit-rsh_0.17.bb

@@ -37,7 +37,7 @@ CFLAGS += " -D_GNU_SOURCE -Wno-deprecated-declarations"
 LDFLAGS += " -L${STAGING_LIBDIR} -lutil -lcrypt"
 
 PACKAGECONFIG ??= ""
-PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
+PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
 PACKAGECONFIG[pam] = " , --without-pam, libpam, libpam"
 
 COMPATIBLE_HOST_libc-musl = 'null'