소스 검색

volume-key: fix "Nothing RPROVIDES" when multilib enabled

Multilib enabled, and add IMAGE_INSTALL_append = " python3-volume-key"
in local.conf

fix below problem:
ERROR: Required build target 'lib32-core-image-minimal' has no buildable providers.
Missing or unbuildable dependency chain was: ['lib32-core-image-minimal', 'lib32-python3-volume-key']

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Changqing Li 4 년 전
부모
커밋
478d0bd9f5
1개의 변경된 파일3개의 추가작업 그리고 4개의 파일을 삭제
  1. 3 4
      meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb

+ 3 - 4
meta-oe/recipes-extended/volume_key/volume-key_0.3.12.bb

@@ -31,8 +31,7 @@ PACKAGECONFIG ??= "python3"
 PACKAGECONFIG[python] = "--with-python,--without-python,python,python"
 PACKAGECONFIG[python3] = "--with-python3,--without-python3,python3,python3"
 
-RDEPENDS_python3-${PN} += "${PN}"
-
-PACKAGES += "python3-${PN}"
-FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
+RDEPENDS_python3-${BPN} += "${PN}"
 
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/*"