Browse Source

python3-babel: Upgrade 2.8.0 -> 2.9.0

Upgrade to release 2.9.0:

- CLDR: Use CLDR 37
- Dates: Handle ZoneInfo objects in get_timezone_location,
  get_timezone_name
- Numbers: Add group_separator feature in number formatting
- Dates: Correct default Format().timedelta format to 'long' to
  mute deprecation warnings
- Import: Simplify iteration code in "import_cldr.py"
- Import: Stop using deprecated ElementTree methods
  "getchildren()" and "getiterator()"
- Messages: Fix unicode printing error on Python 2 without TTY.
- Messages: Introduce invariant that _invalid_pofile() takes
  unicode line.
- Tests: fix tests when using Python 3.9
- Tests: Remove deprecated 'sudo: false' from Travis configuration
- Tests: Support Py.test 6.x
- Utilities: LazyProxy: Handle AttributeError in specified func
- Utilities: Replace usage of parser.suite with ast.parse

License-Update: Update year

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Leon Anavi 3 years ago
parent
commit
4599fea881
1 changed files with 2 additions and 3 deletions
  1. 2 3
      meta-python/recipes-devtools/python/python3-babel_2.9.0.bb

+ 2 - 3
meta-python/recipes-devtools/python/python3-babel_2.8.0.bb → meta-python/recipes-devtools/python/python3-babel_2.9.0.bb

@@ -1,10 +1,9 @@
 DESCRIPTION = "A collection of tools for internationalizing Python applications"
 HOMEPAGE = "http://babel.edgewall.org/"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=942469df9305abb1c59e95f778310384"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=22a580b27e4ebf9689e466b63aedeb7f"
 
-SRC_URI[md5sum] = "6fad9772e75421969ddb41975483abdf"
-SRC_URI[sha256sum] = "1aac2ae2d0d8ea368fa90906567f5c08463d98ade155c0c4bfedd6a0f7160e38"
+SRC_URI[sha256sum] = "da031ab54472314f210b0adcff1588ee5d1d1d0ba4dbd07b94dba82bde791e05"
 
 PYPI_PACKAGE = "Babel"