Bladeren bron

nostromo: make sure usr/group www-data exist

CQID: 422203

nostromo runs as user/group www-data and needs these
to exist when we install it.

Signed-off-by: Joe Slater <jslater@windriver.com>
Joe Slater 10 jaren geleden
bovenliggende
commit
45777abe87
1 gewijzigde bestanden met toevoegingen van 6 en 1 verwijderingen
  1. 6 1
      meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb

+ 6 - 1
meta-webserver/recipes-httpd/nostromo/nostromo_1.9.5.bb

@@ -18,7 +18,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
 
 DEPENDS = "openssl"
 
-inherit update-rc.d
+inherit update-rc.d useradd
 
 INITSCRIPT_NAME = "nostromo"
 INITSCRIPT_PARAMS = "defaults 70"
@@ -27,6 +27,11 @@ do_compile() {
     oe_runmake
 }
 
+# we need user/group www-data to exist when we install
+#
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system -g www-data www-data"
+
 do_install() {
     install -d ${D}/${sbindir}
     install -m 0755 src/nhttpd/nhttpd ${D}/${sbindir}/nhttpd