Browse Source

ttf-droid: Delete from staging install area instead of sources

* This leaves the sourcedir unmodified
* Add -f option to rm to not fail if file is not there

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 5 years ago
parent
commit
390498950f
1 changed files with 6 additions and 2 deletions
  1. 6 2
      meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb

+ 6 - 2
meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb

@@ -12,8 +12,12 @@ SRC_URI = "git://github.com/android/platform_frameworks_base.git;branch=master"
 
 S = "${WORKDIR}/git/data/fonts"
 
-do_install_prepend() {
-    rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it
+do_install_append() {
+    for f in Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf \
+             Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf \
+             DroidSansFallbackLegacy.ttf; do
+        rm -f ${D}${datadir}/fonts/truetype/$f
+    done
 }
 
 PACKAGES = "ttf-droid-sans ttf-droid-sans-mono \