瀏覽代碼

mariadb: not use the bundled libpcre2

>From mariadb 10.5.1, it starts to use pcre2 [1] which is the bundled
libpre2 by default. If using the bundled one, it will fetch, unpack
and build the libpcre2 during mariadb do_compile phase as mariadb uses
the bundled libpcre2 as an external project, more details in [2].

To avoid downloading the libpcre2 source from website during mariadb
do_compile phase, switch to use the system libpcre2.

[1] https://mariadb.com/kb/en/pcre/
[2] https://github.com/MariaDB/server/blob/10.5/cmake/pcre.cmake

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Mingli Yu 3 年之前
父節點
當前提交
3478865459

+ 1 - 1
meta-oe/recipes-dbs/mysql/mariadb-native_10.5.4.bb

@@ -2,7 +2,7 @@ require mariadb.inc
 inherit native
 
 PROVIDES += "mysql5-native"
-DEPENDS = "ncurses-native zlib-native bison-native"
+DEPENDS = "ncurses-native zlib-native bison-native libpcre2-native"
 
 RDEPENDS_${PN} = ""
 PACKAGES = ""

+ 1 - 0
meta-oe/recipes-dbs/mysql/mariadb.inc

@@ -77,6 +77,7 @@ EXTRA_OECMAKE = "-DWITH_EMBEDDED_SERVER=ON \
                  -DNROFF=FALSE \
                  -DENABLE_DTRACE=FALSE \
                  -DWITH_PIC=ON \
+                 -DWITH_PCRE=system \
                  -DINSTALL_LAYOUT=RPM \
                  -DINSTALL_DOCDIR:PATH=${datadir}/doc/${BPN} \
                  -DINSTALL_LIBDIR:PATH=${baselib} \

+ 1 - 1
meta-oe/recipes-dbs/mysql/mariadb_10.5.4.bb

@@ -2,7 +2,7 @@ require mariadb.inc
 
 EXTRA_OECMAKE += "-DSTACK_DIRECTION=-1"
 
-DEPENDS += "mariadb-native bison-native curl openssl ncurses zlib libaio libedit libevent libxml2"
+DEPENDS += "mariadb-native bison-native libpcre2 curl openssl ncurses zlib libaio libedit libevent libxml2"
 
 PROVIDES += "mysql5 libmysqlclient"